[Client download] [macOS] Play Eden on your Mac seamlessly

Post about recruitment, items for sale, game mechanics, et cetera.

Moderator: Moderator

cieltaru
Posts: 2
Joined: Mon Sep 09, 2019 8:06 am

[Client download] [macOS] Play Eden on your Mac seamlessly

Post by cieltaru » Mon Sep 09, 2019 9:15 am

Hi all,

I bring you a one-click application to play FFXI on your Mac - No Bootcamp is required; Using this you won't need Windows to play on your Mac.

In a nutshell, this is a Wine 64 bits wrapper pre-configured to run on FFXI on Eden, it provides:
- Good performance
- No graphical bugs or issues (so far not encountered by me)
- Gamepad support:
  • PS2 connected by USB with adapter
    PS3 or PS4 controllers connected by USB or Bluetooth.
    I haven't tested other gamepads but they may work.
- Compatibility with Ashita addons & plugins. Ashita UI will not directly work, however, this client is using an injector provided by atom0s which allows running Ashita bypassing its UI (pretty useful when .NET runtime does not work on Wine!). You will be able to configure Ashita and its plugins, check the first-time setup for it.

Requirements
- macOS Mojave or older. This wrapper is not compatible with Catalina (10.15). It is recommended to not update to Catalina until an update is provided.
- Any Mac with Intel x86 dual-core processor or superior. Tested with base Macbook Pro 13", mid-2014, 8 GB RAM with embedded Intel graphics.

First-time setup
You will need to configure some settings so the client uses your Eden account and game graphics are adapted to your machine, please follow the next steps:
1. Move "Final Fantasy XI - Eden" to your Applications folder
If you're stuck trying to open the application, go to Troubleshooting at the bottom of this post
2. Right-click the icon > Show Package Content, then go to:

Code: Select all

"drive_c/Program Files (x86)/PlayOnline/Ashita/config/boot"
3. Edit "Eden.xml". Carefully add the following information:

The resolution, for a 1920x1080 monitor, add horizontal and vertical pixel size values, e.g.

Code: Select all

  <setting name="window_x">1920</setting>
  <setting name="window_y">1080</setting>
  
  <setting name="menu_x">1920</setting>
  <setting name="menu_y">1080</setting>
3D rendering graphics resolution. I suggest adding 1024 in both values, the game graphics won't look sharp but you can test it and if the game runs smoothly you can upgrade to 2048/2048 or even 4096/4096. This will depend on your mac graphics power. The game runs better on Wine using values based on the power of two for this setting, that's why we're adding 1024, 2048, 4096, and so on:

Code: Select all

  <setting name="background_x">1024</setting>
  <setting name="background_y">1024</setting>
Add your login credentials for Eden, the "Final Fantasy XI - Eden" client will connect automatically using this credentials. You won't see the console/shell as usual. Replace "edenuser" and "edenpassword" as below:

Code: Select all

<setting name="boot_command">--username edenuser --password edenpassword</setting>
Optionally, edit Ashita configuration under:

Code: Select all

"drive_c/Program Files (x86)/PlayOnline/Ashita/scripts/Default.txt"
Download the latest client here

Changelog
v1.0.0
- Based on Eden Installer 4.1
- Uses the new Eden bootloader (July 2019)
- Runs under Wine 4.15 64 bits
- Ashita v3 is included. Configured with the following plugins and addons:
GearLock, WatchEXP, FPS, TParty, Distance, Recast, Timestamp, and DrawDistance
- Includes XI View re-worked UI menu, fonts, and icons, more info here:
https://github.com/Caradog/XI-View
  • Note from XI View docs:
    for Icons to work make sure in Game you go to this menu setting. Menu - Config - Misc. > Icon Type 2
- Gamepad is pre-mapped for a Dualshock friendly setup.

Troubleshooting
I get an error saying the Application is damaged when I run it for the first time
macOS is really strict with unsigned apps, you must disable Gatekeeper to run it. For that, do the following:
1. In a terminal, execute the following command:

Code: Select all

sudo spctl --master-disable
You'll be asked for your user password
2. Verify Allow apps downloaded from: Anywhere is checked under System Preferences > Security & Privacy > General
The application should work now.

The game opens but my gamepad does not work
1. Ensure the controller is connected to you Mac under System Preferences > Bluetooth.
2. Disconnect the controller to your mac by removing the USB cable.
3. Run the client.
4. Once in-game, re-connect the USB cable to the controller.